Psi Lambda LLC | Parallel computing made practical.

Kappa for Linux


The NVIDIA Driver version 260.XX or higher is needed for all CUDA 3.2 software–including Kappa version 1.4 or higher. The NVIDIA Driver version 256.XX or higher is needed for all CUDA 3.1software–including Kappa version 1.3 or higher. The NVIDIA Driver version 195.36.15 or higher is needed for all CUDA 3.0 software–including Kappa versions 1.0 – 1.2. You will need the CUDA Toolkit to work with CUDA and compile Kappa examples and extensions. The SDK is not needed but it does have interesting CUDA kernel examples.

To import the Psi Lambda LLC GPG key to the rpm database, run the command:
rpm --import http://psilambda.com/download/kappa/linux/prereq/PSILAMBDA-RPM-GPG.KEYS
Kappa Linux should be able to (but may not) install and run on any LSB compatible distribution. Please leave a comment on this page or in the forums if you encounter platforms that are supported by NVIDIA but that the Kappa Library does not (currently) run on. It appears that the Kappa Library compiled with GCC 4.1 does not work on systems which are primarily compiled with GCC 4.4.4 such as Fedora 13–so there is a fc13 version of the rpm’s below for systems using GCC 4.4.4. Debian based distributions such as Ubuntu may use the packages provided below or may use Alien to convert and then install the rpm packages–see the Quick Start guide for details.

Kappa Linux OpenGL

Kappa Linux without Graphics

Kappa Ubuntu OpenGL

Kappa Ubuntu without Graphics

Linux Prerequisites

For convenience, some of the Fedora EPEL 5 packages that are prerequisites of Kappa are available in the following downloads. PCRE version 7.8 may not yet be available from EPEL and is made available here. APR 1.4.2 and APR-UTIL 1.3.9 are not yet available from EPEL and are made available here.

No comments yet.

Leave a Reply

You must be logged in to post a comment.

Articles